AWS US-East-1 Impact

Incident Report for Tendo Systems

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 19:10 CDT

Identified

Tendo systems are impacted as a result of AWS US-East-1 incident. We'll continue to monitor and post updates accordingly. Thank you for your patience and understanding.
Posted Oct 20, 2025 - 11:39 CDT
This incident affected: Marketplace, QDI, CareConnect, and Insight Explorer.